Back to overview
Resolved

Verifications products maintainence

Jul 28, 2026 at 4:05pm UTC  –  Jul 28, 2026 at 4:20pm UTC
Affected services
FaceMatch & ID Check

Resolved
Jul 28, 2026 at 4:20pm UTC

Maintenance ended

Created
Jul 28, 2026 at 4:05pm UTC

We are performing scheduled maintenance on the infrastructure that powers our FaceMatch and ID Check services. During this window, face match and ID check requests may experience delays or temporarily fail to process. No customer data is affected, and all other services continue to operate normally. We expect service to be fully restored shortly and will update this page as soon as maintenance is complete.